Zend Server Community Edition vs Snow Leopard

After upgrading to Snow Leopard we’ve had only one real issue so far, Zend Server Community Edition didn’t want to start up. Well, technically, parts of it. The apache instance was running, by mysql and the admin interface were dead. I found this post about watchdog errors, but even after putting in the fix for lighthttpd I still wasn’t getting the services starting up. Same deal for Tony. Poking around in the startup files it looked like mysql data was owned by user 103, and the mysql scripts were trying to start as user ‘zend’, however I have no zend user on my system. I wasn’t able to find anything about it, but I figured hell, let me give it a try and create a user Zend. This is the command to run from the terminal (funky huh?):

sudo dscl . -create /Users/zend UniqueID 103

Which creates a zend user.. somewhere.. I’m not familiar with that bit of OS X magic yet. It’s not in /etc/passwd, but if you ‘ls -l /usr/local/zend/mysql’ you should see the data directory owned by zend again. Now just restart and you should be peachy:

sudo /usr/local/zend/bin/zendctl.sh restart

Works for Tony and I at least, so we figured we would share. голова болит секс голова болит секс

This entry was posted in Open Source, Software, Technology. Bookmark the permalink.

10 Responses to Zend Server Community Edition vs Snow Leopard

  1. Cheers for this post…worked for me also. Thanks Again Gower

  2. Andrew Cobby says:

    Didn’t work for me. I still get Illegal Instruction errors.

  3. Pingback: Zend Server CE and OS X 10.6 Snow Leopard | cobbweb

  4. mike says:

    how did you see it was 103?

  5. Pingback: Snow Leopard and ZendServer CE 4.0.5 - Blog – ShiftEleven

  6. miker says:

    I could see it was 103 by doing an ls -l on the data directory. If there’s no username associated with the user ids for a file owner, the raw number is printed instead of the user friendly name.

  7. Berthold Kremser says:

    Worked for me! Hope Zend will fix this issue soon. Should not be that much of a problem.

  8. mike says:

    I’ve heard there are some wildlife groups trying to get Apple to do more stuff with the actual S.L.’s lol. I don’t know- people are saying it’s good PR for Apple- they should jump on that.

  9. Colin Morris says:

    You might want to do a bit more for completeness.

    sudo dscl . -create /Users/zend uid 103 UserShell /usr/bin/false RealName “ZendServer’s dedicated group”
    – This will create a user with a bit more information and the inability to use a shell on default log in (bit of security there); along with a name so you can see why it exists. Also:

    sudo dscl . -create /Groups/zend gid 103
    – The installer creates a group with a matching gid. Not sure where that’s used, but I think the default installer creates that group even if the uninstaller doesn’t get rid of that group.

    Found the above our running two machines side by side – one that had snow leopard on it before I installed ZendServer; and one that had snow leopard installed afterwards (which is what nuked the zend user and group)

  10. Mario says:

    Thanks for this. I had the same issue on the upgrade to Lion and this solution solves it.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre lang="" line="" escaped="" highlight="">